עיקרי Pc ו- Mac האם הודעות דוא'ל רגישות לאותיות רישיות?

האם הודעות דוא'ל רגישות לאותיות רישיות?



יש הרבה בלבול בשאלה אם כתובות דוא'ל רגישות לאותיות רישיות או לא. יש האומרים שהם, ואילו אחרים טוענים שהם לא. אז מי צודק? במאמר זה נבדוק האם כתובות דוא'ל רגישות לאותיות רישיות או שאינן רגישות לאותיות רישיות.

האם הודעות דוא

מה עושה כתובת אימייל?

כתובת דוא'ל מורכבת משלושה חלקים - החלק המקומי (המכונה גם שם משתמש), הסימן @ וחלק הדומיין. לכל חלק תפקיד משלו והוא כפוף למערכת הכללים שלו. הנה סקירה מהירה.

על פי התקן, החלק המקומי של כתובת הדוא'ל יכול להיות באורך של עד 64 תווים ויכול להיות מורכב ממערכת מוגבלת של תווים. אלה כוללים אותיות אלפבית לטיניות באותיות גדולות וקטנות, מספרים מ -0 עד 9, נקודה ותווים מיוחדים. התווים המיוחדים כוללים '[email protected] # $% ^ & * () _- + = [] {} ~. הוא מחובר לחלק התחום באמצעות הסימן @.

חלק הדומיין יכול להיות באורך של עד 255 תווים. הוא יכול להכיל אותיות של האלף-בית הלטיני (אותיות קטנות וקטנות), מספרים מ -0 עד 9 ומקף. המקף לא יכול להתחיל או לסיים את חלק התחום.

ניתן להשתמש גם בסמלים בינלאומיים, אם כי עוד על כך בהמשך.

האם זה תלוי רישיות?

התשובה הנכונה לשאלה זו היא כן וגם לא. לפי RFC 5321 , החלק המקומי של כתובת הדוא'ל הוא תלוי רישיות. משמעות הדבר היא, שבאופן תיאורטי, [מוגן בדוא'ל] אינו זהה ל [מוגן בדוא'ל] עם זאת, לספקי הדוא'ל יש את החופש להתייחס לחלקים המקומיים כאל רגישים לאותיות רישיות והן כלא רגישים לתיקים.

לדוגמא, [מוגן באמצעות דואר אלקטרוני], [מוגן באמצעות דואר אלקטרוני] ו [מוגן באמצעות דואר אלקטרוני] הם באופן תיאורטי כתובות דוא'ל שונות. קל לראות כיצד הדבר עלול ליצור בעיות ולהפחית את חוויית המשתמש אם שרת דואר בחר להתייחס לחלקים המקומיים כאל רישיות. לכן, ספקים רבים מתייחסים לחלק המקומי של כתובת הדואר האלקטרוני כלא רגיש למקרה.

כיצד לבטל הולו ברוקו - -

באשר לחלק התחום, RFC 1035 קובע שזה תמיד חסר רישיות. המשמעות היא שתוכל לכתוב אותו באותיות קטנות, באותיות קטנות או בכל שילוב בין השניים והדואר האלקטרוני שלך יגיע באותה כתובת. בשימוש מעשי, [מוגן באמצעות דואר אלקטרוני], [מוגן באמצעות דוא'ל] ו- [מוגן באמצעות דוא'ל] הם אותה כתובת דוא'ל.

בפועל

אמנם כתובות דוא'ל תלויות רישיות רק באופן חלקי, אך בדרך כלל בטוח לחשוב עליהן כלא רגישות לאותיות רישיות. כל הספקים העיקריים, כמו Gmail, Yahoo Mail, Hotmail ואחרים, מתייחסים לחלקים המקומיים של כתובות הדוא'ל כלא רגישים לאותיות. עם זאת, עליך לבדוק את הכללים של ספק הדוא'ל שאיתו ברצונך ליצור דוא'ל.

בהתחשב בנקודה הקודמת, ה- RFC 5321 הנ'ל ממליץ ליצור כתובות דוא'ל חדשות עם אותיות קטנות רק כדי למנוע בעיות בלבול ומסירה.

מצד שני, אם לחבר או לעמית שלך יש כתובת דוא'ל עם שילוב של אותיות קטנות וקטנות, מומלץ לכתוב אותה כפי שהיא כשאתה שולח להם דוא'ל. כישלון לעשות זאת עלול לגרום למסירת הדוא'ל. עם זאת, אין זו בעיה עם ספקי דוא'ל גדולים כמו Gmail, Yahoo Mail, Hotmail ואחרים.

בנוסף, Gmail אינו רגיש לנקודות הנמצאות בחלק המקומי של הדוא'ל בכל הנוגע לזיהוי חשבון משתמש. פירוש הדבר שאם קיים החשבון [מוגן באמצעות דוא'ל], לא תוכל לרשום [מוגן באמצעות דואר אלקטרוני] או [מוגן באמצעות דוא'ל]

בִּנאוּם

במקור, ניתן היה לרשום כתובות דוא'ל רק באמצעות אותיות האלף-בית הלטיני, מספרים ומערכת מוגבלת של תווי ASCII מיוחדים. אולם, ה IETF (כוח משימה להנדסת אינטרנט) פיתח לאחר מכן כללים ותקנים להכללת דמויות בינלאומיות.

RFC6530 היה הראשון שכלל והסדיר את השימוש בתווים בינלאומיים. RFC6531 הרחיב על הכללים והתקנים. לאחר מכן, הכללים והתקנים עודכנו באמצעות RFC6532 ו RFC6533 .

כעת תוכל לרשום כתובת דוא'ל באמצעות מגוון רחב של אלפביתים, תווים וסקריפטים. חלק מהשימושים הנפוצים ביותר כוללים תווים לטיניים עם דיאקריטים, אלפבית יווני, תווים סיניים מסורתיים, תווים יפניים (היראגנה, קטאקנה וקאנג'י), אלפבית קירילי, מספר תסריטים הודים, כמו גם מגוון של אחרים.

הכללת כתובות דוא'ל בינלאומיות ותאימות להן משתנה בין ספק לספק. אפילו חלק מהספקים הגדולים אינם תואמים לחלוטין לכתובות בינלאומיות. לדוגמא, גוגל מאפשרת לך לשלוח דוא'ל לכתובת בינלאומית אך היא אינה מאפשרת לך ליצור אחת. ל- Outlook 2016 יש פונקציונליות דומה.

סיכום

שלא כמו החלק של שם הדומיין, החלק המקומי של כתובת דוא'ל תלוי רישיות. עם זאת, ספקי דוא'ל רבים בוחרים להתעלם מרגישות המקרה של החלק המקומי מסיבות מעשיות ולעודד אנשים ליצור מיילים עם אותיות קטנות בלבד.

מאמרים מעניינים

בחירת העורך

איך Wireshark עובד - מדריך פשוט
איך Wireshark עובד - מדריך פשוט
Wireshark הוא כלי רב עוצמה לפתרון בעיות רשת, ניתוח וביקורת אבטחה. זהו מנתח מנות חינמי ומקור פתוח המאפשר למשתמשים לראות מה קורה ברשת שלהם ברמה מיקרוסקופית. מאמר זה יבדוק כיצד
כיצד להשתמש בבקר Xbox One עם מק
כיצד להשתמש בבקר Xbox One עם מק
קל לחבר בקר PS4 למק שלך, אבל מה עם בקר ה- Xbox One? החדשות הטובות הן שזה עובד מצוין, אבל החדשות הרעות הן שזה דורש קצת יותר הגדרה הודות לשימוש של מיקרוסופט בטכנולוגיות אלחוטיות קנייניות. אבל אל דאגה, גיימרים של Xbox One, נראה לכם איך להתחיל ולהפעיל עם בקר Xbox One וה- Mac שלכם.
מיקרוסופט חלונות מלאו 30 - מבט אל העבר
מיקרוסופט חלונות מלאו 30 - מבט אל העבר
הם אומרים שהזמן עובר במהירות ואכן עבור חלק מאיתנו, אנחנו אף פעם לא מבינים כמה זמן אנחנו משתמשים במחשבים ובמערכת ההפעלה היקרה שלנו של מיקרוסופט. מערכת ההפעלה השולחנית הפופולארית ביותר בעולם מלאכה 30. לפני 30 שנה בדיוק, חברת מיקרוסופט פרסמה את ה- GUI הראשון שלה עבור MS DOS, בשם Windows 1.0. זה
כיצד להפוך את שורת המשימות לאטומה ב- Windows 10
כיצד להפוך את שורת המשימות לאטומה ב- Windows 10
כך תוכל להשבית את שקיפות שורת המשימות ולהפוך אותה לאטומה ב- Windows 10
כיצד להסיר התקנה של פורטל מציאות מעורבת ב- Windows 10
כיצד להסיר התקנה של פורטל מציאות מעורבת ב- Windows 10
המבנים האחרונים של Windows 10 מאפשרים למשתמשים להסיר את פורטל מציאות מעורבת בקלות. במאמר זה נראה כיצד ניתן לעשות זאת.
כיצד לבדוק אם תא אינו ריק ב- Google Sheets
כיצד לבדוק אם תא אינו ריק ב- Google Sheets
אם אתה צריך לבדוק אם תא אחד ב- Google Sheets ריק או לא, אתה יכול לעשות זאת ידנית. למעשה, זו כנראה הדרך המהירה ביותר. עם זאת, אם אתה מתמודד עם מספר תאים, זה הופך במהרה ל-
כיצד להוסיף סטטוס ב-ClickUp
כיצד להוסיף סטטוס ב-ClickUp
ClickUp היא אפליקציית ניהול פרויקטים ושיתוף פעולה המיועדת לחברות בכל הגדלים. זה מגיע עם שלל תכונות שימושיות, כגון כלי תקשורת, הקצאות משימות וסרגלי כלים. פונקציה מסודרת נוספת היא סטטוסים, המכונה גם זרימות עבודה. ל